Minimum requirements & older versions

All Categories / Before You Buy, Common Questions, Important Updates

Minimum Requirements

forScore is compatible with iPads running iOS 12.4 or later (aka iPadOS 13 or later), iPhones or iPod Touches running iOS 12.4 or later, and Macs running macOS 11.0 or later. We do not make forScore for any other platforms such as Windows or Android.

Supported devices include the following models or newer: iPad Pro (all models), iPad Air (all models), iPad (5th generation), iPhone 5s, iPod Touch (6th generation), MacBook (2015), MacBook Air (2013), MacBook Pro (late 2013), Mac mini (2014), iMac (2014), iMac Pro (all models), and Mac Pro (2013).

Some features require hardware components or OS updates that are not available for all of the models listed above.

Older Versions

We can not sell or provide older versions of forScore to new users whose devices do not meet the current minimum requirements. Existing customers who purchased forScore before certain dates can still re-download and use these last compatible, unsupported versions of forScore if needed:

OS Version forScore Version Purchased Before
iOS 5/6 5.1.5 October 7, 2013
iOS 7 10.0.4 September 13, 2016
iOS 8 10.2.6 September 19, 2017
iOS 9 10.5.7 April 9, 2019
iOS 10 11.0.4 September 19, 2019
iOS 11 11.2.6 September 16, 2020

Apple is solely responsible for allowing users to re-download previously purchased apps—we do not offer any kind of support for these versions and we cannot assist customers trying to do so. If you need help re-downloading a previously purchased app, please see this Apple support article or use Apple’s support services.

macbook imac catalyst catalina mojave surface amazon fire kindle galaxy samsung

Mark as helpful. 99